Out of Order

I haven’t had much of a chance to go out and gaze at the stars in the past couple of weeks due to a mixture of clouds and the fact that my telescope mount for the Astromaster 114EQ broke the night of December 30th, 2011. I was tightening the thumb screws to attach the optical tube to the mount when all of a sudden there was a SNAP and before I could react the telescope fell to the floor. The mount snapped and there is no DIY fix.
You can see me holding the thumbscrews that connect the telescope to the mount, along with the mount broken there. At the moment of the picture the telescope was laying on the floor. Fortunately after going through and giving the OTA a thorough check it didn’t seem to be damaged, but it may need a good collimation after falling about 3 feet to the ground. I can’t describe how scared I was to look into the tube expecting to see a shattered mirror.
I have contacted Celestron and they will replace the part, sending out the broken part to be replaced this week. Unfortunately they are saying it could take 4-6 weeks until I receive my new mount. Until then I still have the 70mm refractor although I can’t really take pictures with it, and it’s been quite cold so sketching my views is a bit of a hassle.
I’m also looking into a new telescope – The Omni XLT 150 – which will be a nice addition to my small telescope collection. Keep an eye out I will hopefully be back up and running as normal hopefully within a couple of weeks. Sorry about any lack of viewing updates.